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Introducing Drawing Basics and Concepts

° Drawing a model in 3D is different from drawing an image in 2D.

° This introduction to drawing basics and concepts explains a few ways you can create edges and faces
(the basic entities of any SketchUp model).

° You also discover how the SketchUp inference engine helps you place those lines and faces on your
desired axis.
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Drawing a line

Use the Line tool to draw edges (also called line entities).

(e]

o Edges form the structural foundation of all models.

(e]

Select the Line tool ( /) on the toolbar (or press the L key).

o

The cursor changes to a pencil.

o

Click to set the starting point of your line.

o

If you click the wrong place, press the Esc key to start over.
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Drawing a line

> As you move your cursor around the drawing area, notice the following:
* Aline follows your cursor.

* The line length is displayed dynamically in the Measurements box. (The Measurements box uses the
units specified in your template.)

* The line that’s following your cursor turns red, green, or blue whenever the line is parallel with the
red, green, or blue axis, respectively.

* If you hover for a moment, a ScreenTip appears (that’s the SketchUp inference engine).
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Drawing a line

Click to set the line’s end point.

This end point can also be the starting point of another line.

Press Esc or select a different tool when you’re done drawing lines.

After you set the end point, you can press Ctrl+Z (Microsoft Windows) or Command+Z (Mac OS X) to
undo your line and start over.
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Drawing a line

To make your line a precise length, type a value and press Enter (Microsoft Windows).

(e]

(e]

You can repeat this process as many times as you like until you draw a new line or select another tool.

(e]

If you don’t specify a unit, SketchUp uses the unit specified in your template.

(e]

However, you can type any imperial or metric unit for your line.

(e]

So, you can type 3mm or 5’2" for example. Your value appears in the Measurements box as you type.
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Drawing a line

° The Measurements box also accepts 3D coordinates for lines:

* An absolute coordinate, such as [3’, 5, 7’], places the end of the line relative to the current axes.
Square brackets indicate an absolute coordinate.

* A relative coordinate, such as <1.5m, 4m, 2.75m>, places the end of the line relative to the starting
point of your line. Angle brackets indicate a relative coordinate.
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Drawing a line

You can edit the length of a line as long as it doesn’t bound a face.
Select the Move tool («§»).
Hover the Move tool cursor over one of the line’s end points.

(e]

(e]

(e]

(e]

Click and drag the end point to change the line’s length.
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Creating a face

> When you join several lines into a shape, they form a face.

o By default, SketchUp adds shading to some faces, and the faces are opaque, so you know your model
has an actual wall, floor, or whatever your face is supposed to represent in your 3D model.

° The shape tools — Rectangle, Circle, and Polygon — also create faces.
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Dividing faces

> When you draw a line (or a curve) on an existing face, you split the face.

° This concept is important because, after you split a face, you can use the Push/Pull tool ( ¢ ) to push or

pull one part of the face while the other part stays put. @r+0F 2@ err% e
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Opening 3D shapes by erasing edges and
faces

> You can erase an edge or face to create an opening in a shape.

o To see how erasing an edge affects your model, first select the Eraser tool ( &7 ) in the toolbar or press
the E key, and then click an edge:

* Clicking an edge erases the edge and any face that touched that edge.
* Context-clicking a face and choosing Erase deletes only the face.
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Opening 3D shapes by erasing edges and
faces

° If you want to hide a line instead of erasing it, context-click the line and select Hide.
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Finding and locking an inference

o SketchUp has an inference engine that helps you work in 3D space.

° For example, when the Line tool cursor is hovering over the midpoint of another line, the inference
engine tells you by displaying a light blue dot and ScreenTip that says “Midpoint”.

o Every inference has its own color and ScreenTip. (will be discussed later in this chapter).

Select end point or enter value
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Finding and locking an inference

° The inference engine can also help you find geometric relationships between lines.

° For example, it tells you when a line you’re drawing is perpendicular to another line.

° In the following figure, notice that a colored dot also appears at the start point of the line, giving you a
few bits of information all at once.

| Pempendicular to Edg&l
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Finding and locking an inference

o Pay close attention to the inference engine and orbit occasionally to check your drawing from different

viewpoints.

° In the following figure, the lines might appear to be on the red and green plane until you orbit to a
different view.

° To avoid this common pitfall, SketchUp helps by turning your drawing direction or drawing plane red,
green, or blue when you're creating edges or planes parallel to those axes (or magenta if you're

parallel/perpendicular to an edge or face in your model).
Al MEEE Y FE= DAL S 1 VAR Al ME I E-X4 Pl f APrewa

ITEC185 - INTRODUCTION TO DIGITAL MEDIA




Knowing your inference types

o SketchUp displays several types of inferences: point, linear, and shape.

o SketchUp often combines inferences together to form a complex inference.
> Also, components and dynamic components have their own inference types.
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Knowing your inference types

o A point inference is based on the exact point of your cursor in your model.
o The following table lists the point inference types.

Point Inference .
What It Looks Like What It Means
Type
Endpoint ; . End of a line, arc, or arc segment
Endpoint
L / Middle point on a line, edge, or arc
Midpoint ——
Midpoint segment
Arc Midpoint \/ Middle point on an arc
‘Arc Midpoint
, / Point where a line intersects another line
Intersection -
i Intersection or face
, i Point where an edge that is generated by a
Intersection with , i , _
Hidden Section T T hidden section plane intersects with the
drawing tool
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Knowing your inference types

Ve

On Face A point that lies on a face
On Edge A point that lies on an edge
- ’ -
Center ® Center of a circle, arc, or polygon
Guide Point p Guide Poirt] A guide point
On Line / A point along a guide line

'On Line
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Knowing your inference types

> A linear inference snaps along a line or direction in space.

° In addition to a ScreenTip, a linear inference sometimes displays a temporary dotted line while you
draw.

Linear

What It Looks Like What It Means
Inference Type

Linear alignment to the red drawing axis (Click

On Red Axi
M Red AXIS /7 and drag as you draw to see the inference.)

On Red Axis

On Green Axis l yd Linear alignment to green drawing axis (Click and

|On Green Axis| drag as you draw.)
On Blue Axis 7 Linear alignment to the blue drawing axis (Click
On Blue Axis and drag as you draw.)
_ / Linear alignment from a point; the dotted line's
From Point :, : o .
,|From Point color corresponds to the axis direction
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Knowing your inference types

Through Point

4

Draw from one point, hover over another point
then hold Shift to lock the direction from the
start of the drawing through the second point.

Parallel

~~ |Parallel to Edge

Parallel alignment to an edge

Extend Edge

~/

Extend Edge

Continuation of an existing edge

Perpendicular

~7

|Perpendicular to Edge|

Perpendicular alignment to an edge

Tangent at
Vertex

f“*;|

Tangent at vertex

Arc whose vertex is tangent to a previously drawn
arc's vertex
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Locking inferences with a keyboard

By locking inferences, you can confidently draw along the direction you intend to draw.

Another reason to lock an inference is to maintain one drawing direction while you reference geometry
from another part of the model.

o

o

o

That’s a more advanced move, but very helpful.
The easiest way to lock an inference to the default axes directions is to use the arrow keys:

o

e
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Locking inferences with a keyboard

Key What it looks like
T Locks the drawing direction or drawing plane to the Blue axis
«— Locks the drawing direction or drawing plane to the Green axis

Locks the drawing direction or drawing plane to the Red axis. A good way to
remember left from right is to say “Right locks Red.”

Toggle to lock the parallel/perpendicular drawing direction or drawing plane to an
l inferenced edge or plane. Basically, anything that turns magenta. The drawing
direction will turn magenta in color as well as the edge of face that is being inference.

Locks the drawing direction or drawing plane to the active drawing direction/plane.
Shift | Soif you're drawing along the Blue axes and hold down Shift, the Blue inference will
lock.
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Locking inferences with a keyboard

° Some tools, like the circle and rotate tools, can lock to a plane (instead of a drawing direction).

> For these tools you can lock the drawing plane by choosing the colored direction for the tool’s axis or
“normal”.
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Ensuring edges are alighed to axes

° To ensure your edges align to axes, you may find it helpful to change the cursor to the axes colors.

° Or, if you need to check the alignment of existing geometry, change your edges to the axes colors.
> To change your cursor to axes colors, follow these steps:

* Select Window > Preferences (Microsoft Windows) or SketchUp > Preferences (Mac OS X). The
System Preferences dialog box appears.

Select the Drawing item on the left.

In the Miscellaneous area of the Drawing panel, select the Display cross hairs checkbox.

Click OK to close the System Preferences dialog box.

The cursor displays cross hairs that are the color of the axes.
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Ensuring edges are alighed to axes
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Ensuring edges are alighed to axes

o To make the edges in your model reflect the axis color to which it is aligned, follow these steps:
* Select Window >Default Tray > Styles.

In the Styles dialog box, select In Model from the drop-down list of styles libraries.
Click the Edit tab.

Click the Edge Settings icon.

From the Color drop-down list, select By axis.

The colors of the edges in your model change to reflect their alignment to the axes (unless an edge
isn’t aligned to an axis, and then the edge color does not change).
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Ensuring edges are alighed to axes
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Ensuring edges are alighed to axes
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Adding Premade Components and
Dynamic Components

o SketchUp components enable you to reuse objects.

o For example, pretty much every building has at least one door and window.

° Instead of modeling these common objects, you can insert a component that someone else has already
made.

o Before you start inserting components, you need to know that every component has a definition and an
instance:

* A component definition provides a blueprint for how all components of a specific type appear and
behave in the drawing area.

* When you insert a component into a model, you create a component instance, which is based on its
definition.

ITEC185 - INTRODUCTION TO DIGITAL MEDIA 29




Adding Premade Components and
Dynamic Components
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Adding Premade Components and

Dynamic Components
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Adding Premade Components and
Dynamic Components

° Dynamic components have even more capabilities than regular components. If a component is dynamic,
it has at least one of the following elements:

* Constrained values: For example, a dynamic cabinet door component might have a frame that’s
constrained to 3 inches. Whether the panel inside the frame is 12 x 24 inches or 24 x 48 inches or
some other dimension, the frame remains 3 inches wide all the way around the door.

* Repetitive elements: A dynamic component can have subcomponents that repeat as you scale the
component. For example, a repetitive dynamic component might add steps to a staircase, cushions to
couch, pickets to a fence, studs to construction framing, and so on.

* Configurable values: A dynamic component can have a predefined set of values that you can
configure, such as a couch’s length or the picket spacing in a fence component.

* Animated features: An animated dynamic component moves when you click it with the Interact tool
( %%~ ). With animated dynamic components, your model can have doors and windows that open.
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Adding Premade Components and
Dynamic Components
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Adding Premade Components and
Dynamic Components
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Adding Premade Components and
Dynamic Components
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