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Lesson13-Filtering Data 

Introduction 

 

Filters can be used to narrow down the data in your worksheet 
and hide parts of it from view. While it may sound a little like 
grouping, filtering is different in the way that it allows you to 
qualify and display only the data that interests you. For 
example, you could filter a list of survey participants to view only 
those who are between the ages of 25-34. You could also filter 
an inventory of paint colors to view anything that contains the 
word "blue," such as "bluebell" or "robin's egg blue." 

In this lesson, you will learn how to filter the data in your 
worksheet to display only the information you need. 

 

Filters can be applied in many different ways to improve the 
performance of your worksheet. You can filter text, dates, and 
numbers. You can even use more than one filter to further 
narrow down your results. 

To Filter Data: 

In this example, we will filter the contents of an equipment log at 
a technology company. We will display only the laptops and 
projectors that are available for check-out. 
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1. Begin with a worksheet that identifies each column using a 
header row. 

Worksheet with 
header row 
2. Select the Data tab, and locate the Sort & Filter group. 
3. Click the Filter command. 

Clicking the filter command 

4. Drop-down arrows will appear in the header of each column. 
5. Click the drop-down arrow for the column you would like to 

filter. In this example, we will filter the Type column to view 
only certain types equipment. 
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Filtering a column 

6. The Filter menu appears. 
7. Uncheck the boxes next to the data you don't want to view. 

(You can uncheck the box next to Select All to quickly 
uncheck all.) 

8. Check the boxes next to the data you do want to view. In 
this example, we will check Laptop and Projector to view 
only those types of equipment. 

Selecting filter 
data 
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9. Click OK. All other data will be filtered, or temporarily hidden. 
Only laptops and projectors will be visible. 

Filtered 
worksheet 

Filtering options can also be found on the Home tab, condensed 

into the Sort & Filter command. 

  

To Add Another Filter: 

Filters are additive, meaning you can use as many as you need to 

narrow down your results. In this example, we will work with a 

spreadsheet that has already been filtered to display only laptops 

and projectors. Now we will display only laptops and projectors 

that were checked out during the month of August. 

1. Click the drop-down arrow where you would like to add a 
filter. In this example, we will add a filter to the Checked Out 
column to view information by date. 

2. Uncheck the boxes next to the data you don't want to 
view. Check the boxes next to the data you do want to view. 
In this example, we will check the box next to August. 
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Selecting 
filter data 

3. Click OK. In addition to the original filter, the new filter will be 
applied. The worksheet will be narrowed down even further. 

Worksheet with two filters 

To Clear a Filter: 

1. Click the drop-down arrow in the column from which you 
want to clear the filter. 

2. Choose Clear Filter From... 
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Clearing 
a filter 

3. The filter will be cleared from the column. The data that was 
previously hidden will be on display once again. 

To instantly clear all filters from your worksheet, click 

the Filter command on the Data tab. 

 

Advanced Filtering 

To Filter Using Search: 

Searching for data is a convenient alternative to checking or 

unchecking data from the list. You can search for data that 
contains an exact phrase, number, or date, or a simple 
fragment. For example, searching for the exact phrase "Saris 
X-10 Laptop" will display only Saris X-10 Laptops. Searching 
for the word "Saris," however, will display Saris X-10 Laptops, 
and any other Saris equipment, including projectors, digital 
cameras, and more. 

1. From the Data tab, click the Filter command. 
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2. Click the drop-down arrow in the column you would like to 
filter. In this example, we will filter the Equipment Detail 
column to view only a specific brand. 

3. Enter the data you would like to view in the Search box. We 
will enter the word "Saris" to find all Saris brand equipment. 
The search results will appear automatically. 

Entering a search 

4. Check the boxes next to the data you want to display. We 
will display all the data that includes the brand name Saris. 

5. Click OK. The worksheet will be filtered according to your 
search term. 
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Worksheet 
filtered using Search 

  

To Use Advanced Text Filters: 

Advanced text filters can be used to display more specific 
information, such as cells that contain a certain number of 
characters, or data that does not contain a word you specify. In 
this example, we will use advanced text filters to hide any 
equipment that is related to cameras, including digital cameras, 
camcorders, and more. 
1. From the Data tab, click the Filter command. 
2. Click the drop-down arrow in the column of text that you 

would like to filter. In this example, we will filter the 
Equipment Detail column to view only certain kinds of 
equipment. 

3. Choose Text Filters to open the advanced filtering menu. 
4. Choose a filter. In this example, we will choose Does Not 

Contain to view data that does not contain the text we 
specify. 
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Selecting a 
text filter 

5. The Custom AutoFilter dialog appears. 
6. Enter your text to the right of your filter. In this example, we 

will enter "cam" to view data that does not contain those 
letters. That will exclude any equipment related to cameras, 
such as digital cameras, camcorders,camera bags, and the 
digicam printer. 
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Entering filter text 

7. Click OK. The data will be filtered according to the filter you 
chose and the text you specified. 

To Use Advanced Date Filters: 

Advanced date filters can be used to view information from a 
certain time period, such as last year, next quarter, between two 
dates, and more. Excel automatically knows your current date and 
time, making this tool very easy to use. In this example, we will 
use advanced date filters to view only the equipment that has 
been checked out this week. 

1. From the Data tab, click the Filter command. 
2. Click the drop-down arrow in the column of dates that you 

would like to filter. In this example, we will filter the Checked 
Out column to view only a certain range of dates. 

3. Choose Date Filters to open the advanced filtering menu. 
4. Click a filter. We will choose This Week to view equipment 

that has been checked out this week. 
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Selecting a date filter 

5. The worksheet will be filtered according to the date filter you 
chose. 

Worksheet filtered by date 
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To Use Advanced Number Filters: 

Advanced number filters allow you to manipulate numbered data 

in many different ways. For example, in a worksheet of exam 

grades, you could display the top and bottom numbers to view the 

highest and lowest scores. In this example, we will display only 

certain kinds of equipment based on the range of ID #s that have 

been assigned to them.  

1. From the Data tab, click the Filter command. 
2. Click the drop-down arrow in the column of numbers that 

you would like to filter. In this example, we will filter the ID # 
column to view only a certain range of ID #s. 

3. Choose Number Filters to open the advanced filtering 
menu. 

4. Choose a filter. In this example, we will choose Between to 
view ID #s between the numbers we specify. 
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Selecting 
a number filter 

5. Enter a number to the right of each filter. In this example, 
we will view ID #s greater than or equal to 3000, but less 
than or equal to 4000. That will display ID #s in the 3000-
4000 range. 

Entering filter numbers 
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6. Click OK. The data will be filtered according to the filter you 
chose and the numbers you specified. 

Worksheet 
filtered by number 

Challenge! 

1. Open an existing Excel workbook. If you want, you can use 
lesson13 file. 

2. Filter a column of data. If you are using the example, filter 
the Type column so it displays only laptops and "other" 
equipment. 

3. Add another filter by searching for the data you want. If you 
are using the example, search for EDI brand equipment in 
the Item Description column. 

4. Clear both filters. 

5. Use an advanced text filter to view data that does not 
contain a certain word or phrase. If you are using the 
example, display data that does not contain the word "cam." 
(This should exclude any camera-related equipment, such 
as digitalcameras and the camcorder.) 

6. Use an advanced date filter to view data from a certain time 
period. If you are using the example, display only the 
equipment that was checked out last month. 

7. Use an advanced number filter to view numbers less than a 
certain amount. If you are using the example, display all ID 
#s below 3000. 
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Lesson14-Formatting Tables 

Introduction 

 

  

To Format Information as a Table: 

1. Select the cells you want to format as a table. In this 
example, an invoice, we will format the cells that contain the 
column headers and the order details. 

Selecting cells to format as a table 
2. Click the Format as Table command in the Styles group on 

the Home tab.  
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Format as Table command 

3. A list of predefined table styles will appear. Click a table 
style to select it.  

Selecting 
a table style 

4. A dialog box will appear, confirming the range of cells you 
have selected for your table. The cells will appear selected in 
the spreadsheet, and the range will appear in the dialog box. 

5. If necessary, change the range by selecting a new range of 
cells directly on your spreadsheet. 

6. If your table has headers, check the box next to My table 
has headers.  
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Creating a table 

7. Click OK. The data will be formatted as a table in the style 
that you chose. 

Data formatted as a table 

Tables include filtering by default. You can filter your data at any 

time using the drop-down arrows in the headerTo convert a table 

back into "normal" cells, click the Convert to Range command in 

the Tools group. The filters and the Design tab will then 

disappear, but the cells will retain their data and formatting. 
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Modifying Tables 

To Add Rows or Columns: 

1. Select any cell in your table. The Design tab will appear on 
the Ribbon. 

2. From the Design tab, click the Resize Table command. 

Resize Table command 

3. Directly on your spreadsheet, select the new range of cells 
that you want your table to cover. You must select your 
original table cells as well. 

Selecting a new range of cells 

4. Click OK. The new rows and/or columns will be added to 
your table. 
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After adding new rows 

To Change the Table Style: 

1. Select any cell in your table. The Design tab will appear. 
2. Locate the Table Styles group. Click the More drop-down 

arrow to see all of the table styles. 

The More drop-down arrow 

3. Hover the mouse over the various styles to see a live 
preview. 

4. Select the desired style. The table style will appear in your 
worksheet. 
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After changing the table style 

To Change the Table Style Options: 

When using an Excel table, you can turn various 

options on or off to change its appearance. There are six 

options:Header Row, Total Row, Banded Rows, First 

Column, Last Column, and Banded Columns. 

1. Select any cell in your table. The Design tab will appear. 
2. From the Design tab, check or uncheck the desired options 

in the Table Style Options group. 

Table style options 

Depending on the Table Style you're using, certain Table Style 

Options may have a different effect. You may need 

to experiment to get the exact look you want. 
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Challenge! 

1. Open an existing Excel workbook. If you want, you can use 
lesson14 file. 

2. Format a range of cells as a table. If you are using the 
example, format the column headers (Quantity, Description, 
etc.) and the order details. 

3. Add a row or a column. 

4. Change the table style options. If you are using the example, 
add a total row. 

5. Change the table style several times. Take note of how the 
table options may appear different depending on the style 
you use. 

 


