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Title: A WAN Network Using OPNET Modeler


The OPNET is a very powerful network simulator. Main purposes are to optimize cost, performance and availability. The goal of this laboratory is to learn the basics of how to use Modeler interface, as well as some basic modeling theory. The following tasks are considered:

• Build and analyze models.
• Configure the object palette with the needed models.
• Set up application and profile configurations.
• Model a LAN as a single node.
• Specify background utilization that changes over a time on a link.
• Simulate multiple scenarios simultaneously.
• Apply filter to graphs of results and analyze the results.

Before starting working on the Exercise part of this laboratory, one has to read the Preparations part.

Preparations:

To build a network model the workflow centers on the Project Editor. This is used to create network models, collect statistics directly from each network object or from the network as a hole, execute a simulation and view results. See Figure:
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A WAN Network with 3 sub netowrks:

The goal of the lab is to model a WAN composed by several LANs. The task is to model BTH’s WAN. As known BTH stretches over three locations in Blekinge. These three locations are: Karlskrona, Ronneby and Karlshamn. Another task is to determine how the background traffic is affecting FTP traffic on the network. To do this the FTP performance on the network will be modeled, first without background traffic and then with background traffic. Because there is no interest in modeling the details of each LAN you will use available LAN models to model the individual LANs as single nodes.

The first step in setting up the WAN is to specify the overall context for the network with the Startup Wizard.

Steps:

1) Begin by starting up Modeler and create a new project. Select File -> New and click OK

2) Name the new project <lab4> and the scenario no_back_util, then click OK. Write down your project name here: _____________________

3) To create an empty scenario for the Initial Topology, click next when prompted by the Startup Wizard.

4) Next you can specify a map to use as a background for your network. Click Choose from Maps for Network Scale and click Next.

5) Choose Europe from the list and click Next.

6) Now select Lan_Mod_Model_List to be included in your network by clicking on the Include cell and changing the value from No to Yes. Click Next.

7) Finally review your settings and click OK to finish the Startup Wizard. The workspace now shows the specified map and object palette.

8) Zoom in Sweden from the Europe map (Zoom in until you are satisfied).


Note: To work with Modeler’s full set of node and link models would be overwhelming, so the object palette can be configured to show only a specific subset, or model list. Further you can use the standard model list, adapt them for your own needs, or make your own list. For this lab we created LAN_Mod_Model_List. Now you will adapt that model list by adding the LAN node model to it.

9) To open the Configure Palette dialog box click the Configure Palette button in the object palette.

10) Click the Node Models button in the Configure Palette dialog box. Select Included Entries dialog box appears. Find 10BaseT_LAN in the list and change its status from not included to included. (The 10BaseT_LAN icon appears in the object palette)

11) Click OK to close the Configuration Palette dialog box, then click OK again to save the model list as <initials>_LAN_Mod_Model_List-no_back_util.

You will now configure the Application Configuration Object and the Profile Configuration Object. Before you begin constructing the network it’s a good idea to
predefine the profiles and applications that will be used by the LAN. 

12) To configure the Application Configuration Object, open the object palette in the case it is not already open and drag an Application Config object to the project workspace.

13) Right click and select Edit Attributes from the pop-up menu.

14) Click on the question mark next to the name attribute to see a description of the attribute. When done close the attribute description dialog box.
15) Set the name attribute to Application Configuration.
16) Now change the Application Definitions attribute to Default by clicking in the attribute’s Value column and selecting Default from the pop-up list.


Selecting Default configures the application definition object to have the eight standard applications which are: Database Access, Email, File Transfer, File Print, Telnet Session, Video conferencing, Voice over IP Call and Web Browsing.

17) Close the Attributes dialog box by clicking OK. Now you will configure the Profile Configuration Object.
18) Drag a Profile Configuration object from the object palette to project workspace.
19) Right-click on the object and select Edit Attributes.
20) Set the name attribute to Profile Configuration as shown in the box above.
21) Change now the Profile Configuration attribute by clicking in its value column and selecting Edit from the drop-down menu.

Note: Define a new profile and add it to the table.

22) First change the number of rows to 1.
23) Name the new profile LAN Client.
24) Click in the profile’s Start Time (seconds) cell to open the Start Time Specification dialog box.
25) Select constant from the Distribution Name pull-down menu.
26) Set Mean Outcome to 100, the click OK.

Since you will be modeling FTP performance, that application should be included in the profile.

27) Click in the LAN Client’s Applications column and choose Edit from the pop-up menu
28) Change the number of rows to 1. 
29) Let the name to File Transfer (Heavy) by clicking in the cell and selecting the application from the pop-up menu. (By selecting Default as the value for the Application Definition attribute in this object, you enable this list of applications. The list includes 16 entries, a heavy and a light version for each of the eight standard applications.”) 
30) Set the Start Time Offset to Uniform (0,300).
31) Verify and then click OK to close the Applications Table dialog box.
32) Click OK to close the Profile Configuration Table, then click OK once again to close the Attributes dialog box.


You are now ready to begin the construction of the WAN. In this scenario the network contains 2 identical subnets in Karlskrona and Karlshamn. You can create the first subnet in Karlskrona, with its nodes inside it, and then copy the subnet to Karlshamn. You will also copy it to Ronneby and modify it further. 

Hint: A subnet is a single network object that contains other network objects (links,
nodes and other subnets). Subnetworks allow you to simplify the display of a complex network through abstraction. Subnets are useful when organizing your network model. Subnets can be nested within subnets to an unlimited degree.

33) Open the object palette.
34) Place a subnet over Karlskrona, Right-click to turn off node creation.
35) Right-click on the subnet and select set name. Change the name to Karlskrona.
36) The extent of the subnet needs to be modified. The subnet extent is the geographic area covered by the subnet, which may be much larger than the actual area you wish to model.
37) Right-click on the Karlskrona subnet and select Advanced Edit Attributes.
38) Change the x span and y span attributes to 0,25. (The unit of measure of these attributes is determined by the unit of measure of the top-level area, degrees in this case.)
39) Click OK. (In order to see what’s inside subnets just double-click on that subnet icon and the Modeler will change the view. By default, a subnet’s grid properties are based on its parent subnet. You can change them to fit your network.)
40) Double-click on the Karlskrona Subnet. Select View => Set View Properties…
41) Set units to Meters.
42) Set resolution to 10 pixels/m.
43) Uncheck the Visible checkbox for Satellite orbits.
44) Verify that Drawing is set to Dashed.
45) Set division to 10.
46) Click the Close button. (The network in BTH does not require modeling the precise nature of each node in each subnet, so you can represent the subnets with a LAN model.
47) Place a 10BaseT_LAN in the workspace.
48) Right-click on the 10BaseT_LAN and choose the Edit Attribute menu item.
49) You can change the attributes so that it represents a network with a certain number of workstations and a particular traffic profile.
50) Change the LAN model’s name attribute to Office_LAN.
51) Choose Edit… for the Application: Supported Profiles attribute.
52) Change the number of rows to 1.
53) Change the Profile Name to LAN Client, then click OK. (This LAN will now use the LAN Client profile you created earlier. This profile includes the File Transfer (Heavy) application. The LAN will send traffic that models heavy FTP use.)
54) Change the Number of Workstations attribute to 10, then click OK.
55) Close the Edit Attributes dialog box. (You have now modeled a 10 workstation LAN inside the Karlskrona subnet. Further because this LAN model is composed of workstations and links only, it must be connected to a router. The router can then be connected to other routers in the network.)

56) To create a router, drag a BN_BLN_4s_e4_f_sl8_tr4 node from the object palette to the workstation near the Office_LAN node.

57) After naming the new node router connect it to the Office_LAN nodes with a 10BaseT link. Right click to turn off link creation. (The Karlskrona subnet is now configured. Because the subnets in Karlshamn and Ronneby are identical, you can copy the Karlskrona subnet and place it appropriately)

58) To copy the subnet, you must first return to the parent subnet, this is done either by clicking on the Go to Parent Subnetwork button or right click on the workspace to bring up the workspace pop-up menu, then choose Go to Parent subnetwork from the menu.

59) After returning to the parent subnet, select the subnet and copy it, this is done either by clicking Edit=>Copy or by pressing <Control>+c.

60) Now paste the subnet to Karlshamn and Ronneby by selecting Edit=>Paste or by pressing <Control>+v and then click on the Karlshamn and Ronneby region. When done the new subnets appears.

61) You will now have to rename the subnets. To do so right-click on each of the two subnets and choose set name.
62) Next you should connect the Karlshamn and the Karlskrona subnets to Ronneby. To do so select the LAN_Mod_PPP_DS0 link in the object palette.
63) Draw a LAN_Mod_PPP_DS0 link from Karlskrona to Ronneby. (Next a Select Nodes dialog box appears asking which nodes in each subnet are to be endpoints of the link.)
64) For node a, choose the Karlskrona.router node.
65) For node b, choose the Ronneby.router node.
66) Click OK to establish the link.
67) Repeat this process, drawing link from Karlshamn to Ronneby as well. Specify the city’s router as the links endpoints.
68) When done right-click to turn of link creation. (To complete the network, the main office in Ronneby needs to have a switch and a server added to it.)
69) To configure the network in Ronneby double-click on the Ronneby subnet to enter its subnet view.
70) Place one <Bay Network Accelar1050> switch and one ethernet_server node in the workspace.
71) Rename the <Bay Network Accelar1050> node to switch. This is done by right-clicking on each icon and select Set name from the menu.
72) Rename the ethernet_server to FTP.
73) Connect the router and the server to the switch with 10BaseT links. Right-click to turn off link creation, and close the object palette.
74) The Server needs to be configured to support the FTP Application.
75) Open the Attributes dialog box for the FTP server.
76) Choose Edit… for the Application: Supported Services
77) Change number of rows to 1.
78) Select File Transfer (Heavy) from the Name column pop-up menu.
79) Click OK to close the Supported Services dialog box, and then click OK to close the FTP Attributes dialog box.
80) Return to the parent subnet view.
81) Save the project. File => Save. 

Note: You have now created a model to act as a baseline for the performance of the network. Background traffic will now be added to the links connecting the cities. The results from the two scenarios will be compared. We begin with duplicating a scenario to be able to compare the results later.

82) Select Scenarios => Duplicate Scenario…
83) Name the scenario back_util and click OK.
84) Select the link between Karlskrona-Ronneby. Right-click on the link and choose Similar Links from the pop-up menu.
85) Display the Edit Attributes dialog box for the link between Karlskrona-Ronneby.
86) Click in the Value cell for the Background Utilization attribute and select Edit... from the pop-up menu.
87) Click on the Rows value and change it to 3. Press Return.
88) Network studies show that traffic rises gradually over the course of the day as employees/students arrive.
89) Complete the dialog box as shown. (times 0-300-500 and utilization 30-40-50) Then Click OK. (The last step in setting background utilization is to apply the changes made to the Karlskrona-Ronneby link to all the selected links.)
90) Check the Apply Changes to Selected objects check box in the Karlskorna-Ronneby Attributes dialog box.
91) Click OK to close the dialog box. (Note that 2 objects changed appears in the message area0
92) Save the project. File => Save.

Now you have configured two scenarios, one without background utilization and one with background utilization. You are ready to collect data and analyze it. The relevant statistics for this network are:

• Utilization statistics for the links.
• Global FTP download time for the network.

You will now collect statistics in the back_util scenario.

93)  Right-click in the workspace to display the workspace pop-up menu, and select Choose Individual Statistics.
94) Select the Global Statistics => Ftp => Download Response Time (sec) statistic.
95) Select the Link Statistics => point-to-point => untilization --> Statistic.
96) Click OK to close the dialog box. (In order to compare the statistics in the back_util scenario to the no_back_util scenario, the same statistics must be collected in the no_back_util scenario.) you must change scenario and collect statistics.
97) Select Scenarios => Switch to Scenario, then choose no_back_util. 
98) Collect the same statistics that you did in the back_util scenario:
• Global Statistics => Ftp => Download Response Time (sec)
• Link Statistics => point-to-point => untilization -->
99) Close the Choose Results dialog box.
100) Save the project. 

The statistics are now ready to be collected by running the simulations. Instead of running each simulation separately, you can batch them together to run consecutively.
101) Select Scenarios => Manage Scenarios…
102) Click on the Results value for the no_back_util and back_util scenarios and change the value to <collect>.
103) Set the Sim Duration value for each scenario to 30 and the Time Units to minutes. 
104) Click OK.

Modeler will now run simulations for both scenarios. A simulation Sequence dialog box shows the simulation progress. Shut down the dialog box when the simulations are done.

Hint: You are now ready to view the results of the two scenarios. To view the results
105) from two or more different scenarios against each other, you can use the Compare Results feature. With this topic you can also apply different built-in filters to the graphs.”
106) Continue by comparing the results, to do so display the workspace pop-up menu and choose Compare Results.
107) In the Compare Results dialog box, select Object Statistics => Choose From Maps Network => Karlshamn <-> Ronneby[0] => point to point => utilization ->.
108) Further you will also have to change the filter from menu from As Is to time_average. This must be done because utilization varies over the course of a simulation and it is therefore helpful to look at time average for this statistic.
109) Click Show to display the graph. The graph should resemble the one below, though it will not match exactly. 
You may want to look at the utilization of other links to determine the maximum utilization of any link. Let’s look at Global FTP response time.
110) Click the Unselect button in the Compare Results dialog box.
111) Check the Global Statistics => FTP => Download Response Time statistic in the Compare Statistics dialog box.
112) Verify that the filter menu shows time_average, then click Show.

Important warning:
The lab is now completed. Show your result to Lab Assistant. 
(In order to grading)



Homework:
1. Design a WAN network with 6 subnetworks 
· star Topology at least 15 pc 
· and one switch and FTP server main subnetwork
· [bookmark: _GoBack]find at least 3 statics (the result) one global and 2 locals
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