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Lab 5: Introduction to Circuit Synthesis Using ALTERA QUARTUS
1. Objective:

To get familiar with the VHDL development and simulation tools by generating a
full adder circuit entry using the graphical capture. Within the framework of EDA
(Electronic Design Automation), in this Lab we will learn the use of “Quartus”
software to design and test logic circuits. The Quartus program is very popular and
it is used in the construction of many modern devices.

1. Introduction

VHDL is an abbreviation for the VHSIC Hardware Description Language, where
VHSIC is acronym for the Very High-Speed Integrated Circuits. It is originated from
the standardization efforts of US. Department of Defence to provide a convenient
and precise form of communication for the defence contracts. Today, the digital
circuits are mostly implemented with digital programmable logic devices namely
SPLDs CPLDs and FPGAs.

2. Experimental Practice

Part 1: about Quartus and first simple experiment
Step 1. Create a Project: Every new design you make in the Quartus program must

be under a project name. After opening the program, to create a project, click on:
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[File] -> [New Project Wizard]
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After this stage you will see the following project builder screen.




i Mew Project Wizard X

Introduction

The Mew Project Wizard helps you create a new project and preliminary project settings, including the following:

Project name and directory

Name of the top-level design entity
Project files and libraries

Target device family and device
EDA tool settings

* *+ +

You can change the settings for an existing project and specify additional project-wide settings with the Settings command (Assignments

menu). You can use the various pages of the Settings dialog box to add functionality to the project.

[ Don't show me this introduction again

< Back Finish Cancel Help

This screen is the home screen of the project builder. Here you will see which stages
of your project are formed and what you can organize.

Here, press [Next >] button to continue.

On the new screen, you will see the input sections that ask us to enter the directory
and the name of the related project. Please fill in the appropriate information here.

(Project names for the Quartus program is very important.)




il Mew Project Wizard >

Directory, Name, Top-Level Entity

What is the working directory for this project?

‘C:}'Q_Projects,l'Project_’l |

What is the name of this project?

‘Project_‘] |

What is the name of the top-level design entity for this project? This name is case sensitive and must exactly match the entity name in the

design file.

‘Project_‘l |

Use Existing Project Settings...

< Back Finish Cancel Help

The project type display gives you additional setting options for what hardware the
project will be compiled and implemented. Since, we'll simulate our projects on the
program and we won't run on any real hardware, we'll choose the [Empty Project]

option here, and then click the [Finish] button to create our project.




G MNew Project Wizard

Project Type
Select the type of project to create.

® Empty project
Create new project by specifying project files and libraries, target device family and device, and EDA tool settings.

O Project template
Create a project from an existing design template. You can choose from design templates installed with the Guartus Prime software, or

download design templates from the Design Store.
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Once your project is created, you will see a screen like this:
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Step 2. Simple schematic design:

Once you have successfully created your project, we can make a simple design and

simulation process. At this stage, we will use the design below as an example.
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The next step is to create an empty Block Diagram. To do so, click [File] -> [New]
to select Block Diagram / Schematic File on the pop-up menu and click [OK]. At

this stage, an empty design window will be opened.

When you double-click on the empty worksheet that opens, you will see a screen
showing the libraries that are built in the Quartus program. On this screen you will
see Logic gates libraries under the Primitives libraries. Once you have chosen this,

you will come across logical gates that you can use in your designs.

Here, we will include 1 nand2, 1 nor2, 1 and2, 4 inputs and finally 1 output

components as shown in our sample circuit.

Connecting the elements together:

We will place the elements added to the Quartus schematic page by dragging them
with the mouse or selecting the element and moving them with the arrow keys on
our keyboard. After this step, to connect the circuit elements together as required,
place the mouse cursor on the input or output pins of the circuit elements so that it
will inform us that it is ready to make a connection by turning into a symbol related
to the connection. Press the left mouse button and pull the connecting cable / wire to
the other part to be connected. To indicate that the connection to the input is made
correctly, a small square between the wire and the port will appear where the mouse

cursor is located. You can leave the mouse button after this square appears.

Note: If your connection is faulty, there will be a sign similar to ’x’” at the end of
the cable that you connect. This sign shows that the connection has not been made
correctly. In this case, you must right-click on the cable you connect and click

”delete* to delete and reconnect the cable again.
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After connecting our circuit without problems, double-click on the “PIN_ NAME”
pin posts on the input and output pins to name them as in the example.

After all the steps are finished, we can save our project with the combination of [ctrl
+ 5] keys or [File] -> [Save] option.

Schematic Diagram:
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Step 3. Compiling the Project:

We do the compilation of the project with the [Processing -> [Start Compilation]
menu.

If there are no errors in your project, a pop-up menu with “Full compilation was
successful” will appear.

Close the Compiler display.

Step 4. Simulating the Project:

A circuit can be simulated in two ways. The simplest way is to assume that the
logical elements and the interconnecting wires are perfect, so it does not cause delays
in the propagation of the signals throughout the circulation. This is called functional
simulation. A more complex alternative leads to timing simulation, taking into
account all propagation delays. Typically, the functional simulation is used to

confirm the functional accuracy of a circuit as designed. This takes much less time
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because the simulation can be performed using logical expressions that define a
simple circuit. In this course we will use only functional simulation.

Select [File] -> [New] -> [Verification / Debugging Files] -> [University Program
VWEF] and press the "OK" button.

Select [Edit] -> [Insert Node or Bus] from the pop-up window.

Click on the “Node Finder* button.

In the list of the pins, press the Import all button “>>" and click “Start”.

You can change the order of the pins you see on your screen.

Enter [Edit] -> [End Time] menu to set “set end time” to 160 and change the time
type section “ns” -> “us”.

Click the “Overwrite clock” *& button to set the time intervals of our pins to A: 20,
B: 40, C: 80, D: 160.
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Under [Simulation] -> “Run Simulation Functional Settings”




Save your simulation model by pressing [File] -> [Save].

Simulate your project by pressing [Processing] -> [Start Simulation].

Part 2: single-bit full adder

In this section, we will implement a full adder, an 8-bit adder, and compare the
multiplication algorithms by simulation. First of all, build a single-bit full adder
circuit entry Building a single-bit full adder circuit entry.

he full-adder extends the concept of the half-adder by providing an additional carry-
in (Cin) input, as shown in Figure 5.21. This is a design with three inputs (A, B, and
Cin) and two outputs (Sum and Cout). This cell adds the three binary input numbers

to produce sum and carry-out terms

A Cout
B
Gin Sum
A B Cin Sum Cout
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From viewing the truth table, the Sum output is only a logic 1 when one or three (but
not two) of the inputs is logic 1. The Boolean expression for this is (in reduced form):

Sum=Cin@(AEDB)

From viewing the truth table, the Cout output is only a logic 1 when two or three of

the inputs is logic 1. The Boolean expression for this is (in reduced form):
Cout=(A.B)+(Cin.(A@B))

This can be drawn as a circuit schematic as shown in Figure bellow:

—p—
B
N

Follow the on steps part 1 in order to design this circuit:

A—8
B ——® H
Cin
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https://www.sciencedirect.com/topics/computer-science/boolean-expression

e Draw the "Schematic / Block Diagram™ of the above functions using the
Quartus software program.

e Simulate the project showing the WaveForm in the Quartus program
"University program VWF" and show it to the lab assistant.

e Compare the truth table that you wrote in your notebook with the result of the

simulation that Quartus gives you.

Note: be careful about connections.

12




Part 3: 8-Bit Adder

Binary adders are digital circuits often used in computers for basic arithmetic
operations. Using the digital library in the standard Modelica library, we have

constructed an 8-bit adder that takes two 8-bit integers and calculates their sum.

The circuit created is an 8-bit adder. The 8-bit adder adds two 8-bit binary inputs
and the result is produced in the output. In order to create a Full 8-bit adder, I could
use eight Full 1-bit adders and connect them. This way, the least significant bit on
the far right will be produced by adding the first two bits, then it will carry out (if
any) a bit to the next two bits to add. This will continue seven more times until it is
done. In the end, the last carry out will be output.

To create this adder, | implemented eight full adders and connected them together to
create an 8- bit adder. | created a symbol and sub-Design for the full adder I created

for the mini-project we did earlier in the semester:
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Note: There is no exp53 (1-bit full adder) in list of objects, we must create it from
our last section. in order to create exp53 follow these steps:

1. Select BDF file

2. File->Create/Update—>create symbol file for current files

3. Then you can search it in list like other gate or inputs

Note: be careful about the connections.

e Draw the "Schematic / Block Diagram™ of the above functions using the
Quartus software program.

e Simulate the project showing the WaveForm in the Quartus program
"University program VWF" and show it to the lab assistant.

e Compare the truth table that you wrote in your notebook with the result of the

simulation that Quartus gives you.
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Note: The waveform will be like this after simulation (set inputs 10,20,30, . . . .90):
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3. Reporting
Before the Lab-time is over, show the simulation result to your lab assistant, in order

to grading.

4. Homework: build a 4-bit full adder

Any number of half- and full-adder cells can be connected together to form an n-bit
addition. The Figure shows the connections for a four-bit binary adder. In this
design, there is no Cin input. Inputs A and B are four bits wide, and bit 0 (A(0) and
B(0)) are the LSBs.
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e Draw the "Schematic / Block Diagram™ of the above functions using the
Quartus software program.

e Simulate the project showing the WaveForm in the Quartus program
"University program VWF" and show it to the lab assistant.

e Compare the truth table that you wrote in your notebook with the result of the

simulation that Quartus gives you.

Grading:
Lab Performance:

Asst. Observations:
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