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Lesson10-Working with Basic Functions 

 

Figuring out formulas for calculations you want to make in Excel can be tedious 

and complicated. Fortunately, Excel has an entire library of functions or 

predefined formulas that you can take advantage of. You may be familiar with 

common functions like sum, average, product or count, but there are hundreds 

of functions in Excel, even for things like formatting text, referencing cells, 

calculating financial rates, analyzing statistics, and more. 

In this lesson, you will learn the basics of inserting common functions into your 

worksheet by utilizing the AutoSum and Insert Functions commands. You will also 

become familiar with how to search and find various functions, including 

exploring Excel's Functions Library. 

 

A function is a predefined formula that performs calculations using specific 

values in a particular order. One of the key benefits of functions is that they can 

save you time since you do not have to write the formula yourself. Excel has 

hundreds of different functions to assist with your calculations. 

In order to use these functions correctly, you need to understand the 

different parts of a function and how to create arguments in functions to 

calculate values and cell references. 
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The Parts of a Function 

The order in which you insert a function is important. Each function has a specific 

order, called syntax, which must be followed for the function to work correctly. 

The basic syntax to create a formula with a function is to insert an equal sign 

(=), a function name (SUM, for example, is the function name for addition), and 

an argument. Arguments contain the information you want the formula to 

calculate, such as a range of cell references. 

Syntax of a basic function 

  

Working with Basic Arguments 

Arguments must be enclosed in parentheses. Individual values or cell 

references inside the parentheses are separated by either colons or commas. 

 Colons create a reference to a range of cells.  

 

For example, =AVG(E19:E23) would calculate the average of the cell 

range E19 through E23. 

 

 

 Commas separate individual values, cell references, and cell ranges in the parentheses. 

If there is more than one argument, you must separate each argument by a comma.  
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For example, =COUNT(C6:C14,C19:C23,C28) will count all the cells in the three 

arguments that are included in parentheses. 

 

To Create a Basic Function in Excel: 

1. Select the cell where the answer will appear (F15, for example)  

2. Type the equal sign (=) and enter the function name (SUM, for 
example). 

Creating a SUM 
function 

3. Enter the cells for the argument inside the parenthesis. 

Adding cells to the function argument 

4. Press Enter and the result will appear. 

Result 
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Using AutoSum to select Common Functions: 

The AutoSum command allows you to automatically return the results for a 

range of cells for common functions like SUM and AVG. 

1. Select the cell where the answer will appear (E24, for example). 

2. Click on the Home tab. 
3. In the Editing group, click on the AutoSum drop-down arrow and 

select the function you desire (Average, for example). 

AutoSum command 

4. A formula will appear in the selected cell E24. If logically placed, 
AutoSum will select your cells for you. Otherwise, you will need to 
click on the cells to choose the argument you desire. 

AutoSum selects and dsiplays cell 
range 
5. Press Enter and the result will appear. 

Result 

The AutoSum command can also be accessed from the Formulas tab. 
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Function Library 

There are hundreds of functions in Excel, but only some will be useful for the kind 

of data you are working with. There is no need to learn every single function, but 

you may want to explore some of the different kinds to get ideas about which 

ones might be helpful to you as you create new spreadsheets. 

A great place to explore functions is in the Function Library on the Formulas 

tab. Here you may search and select Excel functions based on categories such 

as Financial, Logical, Text, Date & Time, and more.  

 

To Insert a Function from the Function Library: 

1. Select the cell where the answer will appear (I6, for example) 

2. Click on the Formulas tab. 
3. From the Function Library group, select the function category you 

desire. In this example, we will choose Date & Time. 
4. Select the desired function from the Date & Time drop-down menu. 

We will choose the NETWORKDAYS function to count the days 
between the order date and receive date in our worksheet. 
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Function Library Date & Time category 

5. The Function Arguments dialog box will appear. Insert the cursor in 
the first field and then enter or select the cell(s) you desire (G6, for 
example). 
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Selecting cell for the Start-date field 

6. Insert the cursor in the next field and then enter or select the cell(s) 
you desire (H6, for example). 



  

 ITEC106-Excel 2010 Lecture Notes 

Selecting cell for the End_date field 

7. Click OK and the result will appear. Our results show that it took 5 
days to receive the order. 

Result 

Insert Function Command 

The Insert Function command is convenient because it allows you to search for 

a function by typing a description of what you are looking for or by selecting a 

category to peruse. The Insert Function command can also be used to easily enter 

or select more than one argument for a function. 

Using the Insert Function command: 

In this example, we want to find a function that will count the total number of 

supplies listed in the Office Supply Order Log. The basic COUNT function only 

counts cells with numbers; we want to count the cells in the Office Supply 
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column, which uses text. Therefore, we will need to find a formula that counts 

cells with text. 

1. Select the cell where the answer will appear (A27, for example) 

2. Click on the Formulas tab and select the Insert Function command. 

Insert 
Function command 

3. The Insert Function dialog box will appear. 
4. Type a description of the function you are searching for and 

click Go. For our example, we will type: Count cells with text. (You 
may also search by selecting a category.) 
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Searching for a function 

5. Review the results to find the function you desire. We will use COUNTA. Then click OK. 

Reviewing function search 
results 



  

 ITEC106-Excel 2010 Lecture Notes 

6. The Function Arguments dialog box will appear. Insert the cursor in 
the first field and then enter or select the cell(s) you desire (A6:A14, 
for example). 

Selecting cell range for Value1 field 

7. Insert the cursor in the next field and then enter or select the cell(s) 
you desire (A19:A23, for example). (You may continue to add 
additional arguments if needed.) 

Selecting cell range for Value2 field 

8. Click OK and the result will appear. Our results show that 14 Total 
Supplies were ordered from our log. 
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Result 

 

Challenge! 

1. Open an existing Excel 2010 workbook. If you want, you can use 
Lesson10 file. 

2. Create a function that contains more than one argument. 

3. Use AutoSum to insert a function. If you are using the example, insert 
the MAX function in cell E15 to find the highest priced supply. 

4. Insert a function from the Functions Library. If you are using the 
example, find the PRODUCT function (multiply) to calculate the Unit 
Quantity times the Unit Price in cells F19 through F23. 

5. Use the Insert Function command to search and explore functions. 
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Lesson11-Sorting Data 

 

With over 17 billion cells in a single worksheet, Excel 2010 gives you the ability to 

work with an enormous amount of data. Arranging your data alphabetically, from 

smallest to largest, or other criteria, can help you find the information you're 

looking for more quickly. 

In this lesson, you will learn how to sort data to better view and organize the 

contents of your spreadsheet. 

 

Basic Sorting 

Sorting is a common task that allows you to change or customize the order of 

your spreadsheet data. For example, you could organize an office birthday list by 

employee, birthdate, or department, making it easier to find what you're looking 

for. Custom sorting takes it a step further, giving you the ability to sort multiple 

levels (such as department first, then birthdate, to group birthdates by 

department), and more. 

To Sort in Alphabetical Order: 

1. Select a cell in the column you want to sort by. In this example, we 
will sort by Last Name. 
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Selecting a column to sort 

2. Select the Data tab, and locate the Sort and Filter group. 
3. Click the ascending command  to Sort A to Z, or the descending 

command  to Sort Z to A. 

Sorting in ascending alphabetical order 

4. The data in the spreadsheet will be organized alphabetically. 

Sorted by last name, from A to Z 
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Sorting options can also be found on the Home tab, condensed into the Sort & 

Filter command. 

  

To Sort in Numerical Order: 

1. Select a cell in the column you want to sort by. 

Selecting a column to sort 

2. From the Data tab, click the ascending command  to Sort Smallest 
to Largest, or the descending command  to Sort Largest to 
Smallest. 

3. The data in the spreadsheet will be organized numerically. 

Sorted by homeroom number, from 
smallest to largest 

  

To Sort by Date or Time: 

1. Select a cell in the column you want to sort by. 
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Selecting a column to sort 

2. From the Data tab, click the ascending command  to Sort Oldest 
to Newest, or the descending command  to Sort Newest to 
Oldest. 

3. The data in the spreadsheet will be organized by date or time. 

Sorted by payment date, from oldest to 
newest 

 

Custom Sorting 

To Sort in the Order of Your Choosing: 

You can use a Custom List to identify your own sorting order, such as days of 

the week, or, in this example, t-shirt sizes from smallest to largest (Small, 

Medium, Large, and X-Large). 

1. From the Data tab, click the Sort command to open the Sort dialog 
box. 
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Opening the Sort dialog box 

2. Identify the column you want to Sort by by clicking the drop-down 
arrow in the Column field. In this example, we will choose T-Shirt 
Size. 

Selecting a column to sort by 

3. Make sure Values is selected in the Sort On field. 
4. Click the drop-down arrow in the Order field, and choose Custom 

List... 
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Choosing to order by Custom List 

5. Select NEW LIST, and enter how you want your data sorted in 
the List entries box. We will sort t-shirt sizes from smallest to largest. 

6. Click Add to save the list, then click OK. 

Creating a 
custom list 

7. Click OK to close the Sort dialog box and sort your data. 
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Clicking OK to sort 

8. The spreadsheet will be sorted in order of Small, Medium, Large, and 
X-Large. 

Sorted by t-shirt size, 
from smallest to largest 

  



  

 ITEC106-Excel 2010 Lecture Notes 

To Sort by Cell Color, Font Color, or Cell Icon: 

1. From the Data tab, click the Sort command to open the Sort dialog 
box. 

2. Identify the column you want to Sort by by clicking the drop-down 
arrow in the Column field. 

3. Choose whether you want to sort by Cell Color, Font Color, or Cell 
Icon in the Sort On field. In this example, will sort on Font Color. 

Choosing to sort on Font Color 

4. In the Order field, click the drop-down arrow to choose a color, then 
decide whether you want it ordered On Top or On Bottom. 

Selecting a font color 

5. Click OK. The data is now sorted by attribute rather than text. 



  

 ITEC106-Excel 2010 Lecture Notes 

Sorted by font color 

Sorting Multiple Levels 

Another feature of custom sorting, sorting multiple levels allows you to 

identify which columns to sort by and when, giving you more control over the 

organization of your data. For example, you could sort by more than one cell color 

(such as red, then yellow, then green, to indicate different levels of priority); or, 

as seen here, sort students by homeroom number, then by last name. 

  

To Add a Level: 

1. From the Data tab, click the Sort command to open the Sort dialog 
box. 

2. Identify the first item you want to Sort by. In this example, we will sort 
Homeroom # from Smallest to Largest. 

3. Click Add Level to add another item. 
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Adding a level 

4. Identify the item you want to sort by next. We will sort Last Name 
from A to Z. 

Choosing criteria for a second level 

5. Click OK. 
6. The spreadsheet will be sorted so that homeroom numbers are in 

order, and within each homeroom, students are listed alphabetically 
by last name.  
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Sorted by multiple levels 

Copy Level will add a level by duplicating the one you have selected, and 

allowing you to modify the sorting criteria. This is useful if you need to sort 

multiple levels that share some criteria, such as the same Column, Sort On, or 

Order. 

  

To Change the Sorting Priority: 

1. From the Data tab, click the Sort command to open the Custom 
Sort dialog box. 

2. Select the level you want to re-order. 
3. Use the Move Up or Move Down arrows. The higher the level is on 

the list, the higher its priority. 



  

 ITEC106-Excel 2010 Lecture Notes 

Changing the sorting priority 

4. Click OK. 

Challenge! 

1. Open an existing Excel workbook. If you want, you can use Lesson11 
file. 

2. Sort a column in ascending  or descending  order. If you are 
using the example, sort by Homeroom #. 

3. Add a second level, and sort it according to cell color, font color, or 
cell icon. If you are using the example, add a second and third level 
to sort by the red and grey fonts used in T-Shirt Color. 

4. Add another level, and sort it using a Custom List. If you are using the 
example, sort by T-Shirt Size in the order of Small, Medium, Large, 
and X-Large. 

5. Change the sorting priority. If you are using the example, re-order the 
list to sort by T-Shirt Color (red), then by T-Shirt Color (grey), then by 
T-Shirt Size, then by Homeroom #. 
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Lesson12-Outlining Data 

Introduction 

 

If the amount of data in your worksheet becomes overwhelming, creating an 

outline can help. Not only does this allow you to organize your data into groups, 

and then show or hide them from view; you can also summarize data for quick 

analysis using the Subtotal command (for example, subtotaling the cost of office 

supplies depending on the type of product). 

In this lesson, you will learn how to outline your worksheet in order to summarize 

and control how your data is displayed. 

 

Outlines give you the ability to group data that you may want to show or hide 

from view, and create a quick summary using the Subtotal command. Because 

outlines rely on grouping data that is related, you must sort before you can 

outline.  

To Outline Data Using Subtotal: 

The Subtotal command can be used to outline your worksheet in many different 

ways. It uses common functions like SUM, COUNT, AVG, and more, 

to summarize your data, and place it in a group. In this example, we will use the 

Subtotal command to count the number of t-shirt sizes that were ordered at a 

local high school. This will also place each t-shirt size in a group, making it possible 
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to show the count, but hide the details that are not crucial to the placing of the 

order (such as the student's homeroom number and payment date). 

1. Sort according to the data you want to outline. Outlines rely on 
grouping data that is related. In this example, we will outline the 
worksheet by T-Shirt Size, which has been sorted from smallest to 
largest. 

Sorted by t-shirt size 

2. Select the Data tab, and locate the Outline group. 
3. Click the Subtotal command to open the Subtotal dialog box. 
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Opening the Subtotal dialog box 

4. In the At each change in field, select the column you want to use to 
outline your worksheet. In this example, we will choose T-Shirt Size. 

5. In the Use function field, choose from the list of functions that are 
available for subtotaling. We will use the COUNT function to tally the 
number of each size. 

6. Select the column you want the subtotal to appear in. We will choose 
the T-Shirt Size column. 

7. Click OK. 

Clicking OK to subtotal 

8. The contents of your worksheet will be outlined. Each t-shirt size will 
be placed in its own group, and the subtotal (in this case, count) will 
be listed below each group. 
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Outlined with 
subtotal 

 

Showing or Hiding Data 

To Show or Hide a Group: 

1. Click the minus sign, also known as the Hide Detail symbol, to 
collapse the group. 
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Hiding an 
expanded group 

2. Click the plus sign, also known as the Show Detail symbol, to 
expand the group again. 
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Showing a 
collapsed group 

You can also use the  or  commands on the Data tab in 

the Outline group. First select a cell in the group you want to show or hide, then 

click the appropriate command. 

 

To View Groups by Level: 

The groups in your outline, based on their hierarchy, are placed on different 

levels. You can quickly display as little or as much information as you want by 

clicking the level symbols  to the left of your worksheet. In this example, 

we will view levels in descending order, starting with the entire worksheet on 

display, then finishing with the grand total. While this example contains only 3 

levels, Excel can accommodate up to 8. 

1. Click the highest level (in this example, level 3) to view and expand 
all of your groups. Viewing groups at the highest level will display the 
entirety of your worksheet. 
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Viewing data at 
the highest level 

 

2. Click the next level (in this example, level 2) to hide the detail of the 

previous level. In this example, level 2 contains each subtotal. 

Viewing data on 
level 2 

3. Click the lowest level (level 1) to display the lowest level of detail. In 
this example, level 1 contains only the grand total. 
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Viewing data on 
level 1 

Removing Groups and Subtotaling 

To Ungroup Data: 

1. Select the rows or columns that you want to ungroup. In this example, 
we will ungroup size Small. 

Selecting cells 
to ungroup 

2. From the Data tab, click the Ungroup command. The range of cells 
will be ungrouped. 
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Ungrouping the selected cells 

To ungroup all the groups in your outline, open the drop-down menu under 

the Ungroup command, and chooseClear Outline. 

Ungroup and Clear Outline will not remove subtotaling from your worksheet. 

Summary or subtotal data will stay in place and continue to function until you 

remove it. 

  

To Ungroup Data and Remove Subtotaling: 

1. From the Data tab, click the Subtotal command to open the Subtotal 
dialog box. 

2. Click Remove All. 

Removing groups and subtotaling 
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3. All data will be ungrouped, and subtotals will be removed. 

Data without groups or 
subtotaling 

Creating Your Own Groups 

The Group command allows you to group any range of cells - either columns or 

rows. It does not calculate a subtotal, or rely on your data being sorted. This gives 

you the ability to show or hide any part of your worksheet, and display only the 

information you need. 

  

To Create and Control Your Own Group: 

In this example, we will prepare a list of t-shirt colors and sizes that need to be 

distributed to each homeroom. Some of the data in the worksheet is not relevant 
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to the distribution of the t-shirts; however, instead of deleting it, we will group it, 

then temporarily hide it from view. 

1. Select the range of cells that you want to group. In this example, we 
will group the First Name, Last Name, and Payment columns. 

Selecting a range of 
cells to group 

2. From the Data tab, click the Group command. 

Grouping the selected cells 

3. Excel will group the selected columns or rows. 
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Grouped cells 

4. Click the minus sign, also known as the Hide Detail symbol, to hide 
the group. 

5. The group will be hidden from view. 

Click to show a hidden 

group 

 

Click the plus sign, also known as the Show Detail symbol, to show the group 

again. 

Challenge! 

1. Open an existing Excel workbook. If you want, you can use 
this lesson12 file 
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2. Outline your worksheet using the Subtotal command. If you are using 
the example, outline by t-shirt size. 

3. Display the first level of groups in your outline. 

4. Display the highest level to view your entire worksheet again. 

5. Create your own group of rows or columns, then hide the group from 
view. 

6. Ungroup any range of data. 

7. Remove subtotaling from your worksheet. 
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Challenge!Lesson10 

1. Open an existing Excel 2010 workbook. If you want, you can use 
Lesson10 file. 

2. Create a function that contains more than one argument. 

3. Use AutoSum to insert a function. If you are using the example, insert 
the MAX function in cell E15 to find the highest priced supply. 

4. Insert a function from the Functions Library. If you are using the 
example, find the PRODUCT function (multiply) to calculate the Unit 
Quantity times the Unit Price in cells F19 through F23. 

5. Use the Insert Function command to search and explore functions. 

 

Challenge! Lesson11 

1. Open an existing Excel workbook. If you want, you can use Lesson11 
file. 

2. Sort a column in ascending  or descending  order. If you are 
using the example, sort by Homeroom #. 

3. Add a second level, and sort it according to cell color, font color, or 
cell icon. If you are using the example, add a second and third level 
to sort by the red and grey fonts used in T-Shirt Color. 

4. Add another level, and sort it using a Custom List. If you are using the 
example, sort by T-Shirt Size in the order of Small, Medium, Large, 
and X-Large. 

5. Change the sorting priority. If you are using the example, re-order the 
list to sort by T-Shirt Color (red), then by T-Shirt Color (grey), then by 
T-Shirt Size, then by Homeroom #. 
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Challenge! Lesson12 

 

1. Open an existing Excel workbook. If you want, you can use 
this lesson12 file 

2. Outline your worksheet using the Subtotal command. If you are using 
the example, outline by t-shirt size. 

3. Display the first level of groups in your outline. 

4. Display the highest level to view your entire worksheet again. 

5. Create your own group of rows or columns, then hide the group from 
view. 

6. Ungroup any range of data. 

7. Remove subtotaling from your worksheet. 

 


