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What is SketchUp?

It’s software that lets you use your computer to create models of objects and buildings in three
dimensions.

It's not hard to create simple three-dimensional objects and buildings with SketchUp software.
There are lots objects and buildings you can import into your sketch, or you create your own.

SketchUp software is mostly easy to learn and makes a great first step before you move into more
complicated software like Blender (for making characters and movies, as well as objects) and CAD
(computer-aided design) software used professionally.

o

o

o

o
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Getting Started in SketchUp

o When you first run SketchUp, the Welcome to SketchUp dialog box appears, as shown here.

> This dialog box is your starting point for creating a model and appears every time you start SketchUp.

Welcome to SketchUp

ol TR —
Licensed To: SketchUp Make 2016 User, Pro Trial, 18 days

Default Template: Simple Template - Meters

¥ Learn

Find a 3D model of anything

Search 3D Warehouse Buy SketchUp Pro

O@000

: T’emplate
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Getting Started in SketchUp

° In the Welcome to SketchUp dialog box, you can choose a template for your model and learn more
about SketchUp.

Default Template: Simple Template - Meters
N

F Learn

F  License

¥ Template [+ ]
Simple Template - Feet and Inches “

Units: Inches
This is a general user modeling template with basic sting and simple colors.

Choose Template |

BN Simple Template - Meters

Units: Meters

i This is a general user modeling template with basic styling and simple colors.

f Architectural Design - Feet and Inches
| Units: Inches
- ' This template is for conceptual design development.
| Architectural Design - Millimeters
| Units: Milimeters
- ' This template is for conceptual design development.
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Selecting a Template

° Every model in SketchUp is based on a template, which has predefined settings for your model’s
background and units of measurement.

> Here’s how to select a template in the Welcome to SketchUp dialog box:
o At the top of the dialog box, the Default Template field tells you the name of the currently selected
te m p | ate ¢ Welcome to SketchUp

¥ Template
| Simple Template - Feet and Inches
5 Units: Inches
hY This is a general user modeling template with basic styling and simple colors.

BN Simple Template - Meters
Units: Meters

ht This is a general user modeling template with basic styling and simple colors
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Selecting a Template

> To change the template, click the Choose Template button or click the arrow next to the Template tab.
° The Templates tab opens with a list of templates that come with SketchUp, as shown here.

Welcome to SketchUp
] dKE — =
=-4=3 R 61;:‘ .a —
== we—— AN H b
o \'ﬂ P —a N | i ﬂ* Tw” -5
Licensed To: SketchUp Make 2016 User, Pro Trial, 18 days remaining

Default Template: Simple Template - Meters

» Learn

¥ Template

imple Template - Feet and Inches
Units: Inches
This is a general user modeling template with basic styling and simple colors.

BN Simple Template - Meters
N Units: Meters

This is a general user modeling template with basic styling and simple colors

Architectural Design - Feet and Inches
\ | Units: Inches
&; This template is for conceptual design development.

Architectural Design - Millimeters
t& Units: Millimeters
. This template is for conceptual design development.

{ Architectural Design - Meters
| | Units: Meters
ﬁ;" This template is for con ial design dev ent. bz

Start using SketchUp
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Selecting a Template

o Scroll through the list and select your desired template. (Note that the examples in the rest of this
article are based on Simple Template - Feet and Inches.)

o Click the Start using SketchUp button, and SketchUp opens, ready for you to start 3D modeling.

Default Template: Simple Template - Feet and Inches Choose Template |

> Learn
> License
¥ Template [ -]

B> il Simple Templaie - Feet and Inches ”
Units: Inches

i This is a general user modeling template with basic styling and simple colors.

Simple Template - Feet and Incres
L ToImpiE Empia

i Units: Meters

h This is a general user modeling template with basic styling and simple colors.

| Architectural Design - Feet and Inches

|&;\ Units: Inches

This template is for conceptual design development.

| Architectural Design - Millimeters
lg | Units: Milimeters
& This template is for conceptual design development.

| Architectural Design - Meters
| Units: Meters
This template is for conceptual design development.

—
> ~
Start using SketchlUp
N 4

e —
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Title bar

oThe title bar contains the standard window controls (close,
minimize, and maximize) and the name of the currently open file.

Exploring the
SketchUp

interface oD
& Untitled - SketchUp
File iew Camera Draw Tools Window Help

Title bar NG/ O HSBISCH L PR LN ORD

oWhen you start SketchUp, the name of the currently open file is
Untitled, indicating that you have not yet saved your work.

Menu bar

Getting Started toolbar

Drawing area
Status bar - Tips
Status bar - Measurements box

Window resize handle
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Exploring the
SketchUp
interface

Menu bar

Getting Started toolbar

Drawing area
Status bar - Tips
Status bar - Measurements box

Window resize handle

Menu bar

oThe majority of SketchUp tools, commands, and settings are
available within the menus on the menu bar.

oThe menus are: SketchUp (Mac only), File, Edit, View, Camera, Draw,
Tools, Window, and Help.

File Edit WView Camera Draw Tools Window Hel

G700 "0 " SFHSH 2928 22X 08
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Getting Started toolbar

oWhen you begin using SketchUp, the Getting Started toolbar is the
one you see by default.

Exploring the

olt contains the basic tools you need to begin creating 3D models.
SketchUp

i nte rfa Ce B Untitled - SketchUp

—Title bar File _Edit_icumiamerme—ra—To0k Window Help
DG/~ H Y SBSOR I OB e 2L O®a

—Menubar

Getting Started toolbar

Drawing area

Status bar - Tips

Status bar - Measurements box

Window resize handle
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Exploring the
SketchUp
interface

—TFitle-bar
—Menu-bar
Getting Started toolbar

Drawing area

Status bar - Tips

Status bar - Measurements box

Window resize handle

Getting Started toolbar

oTo display additional toolbars, select View > Toolbars.

oln the Toolbars dialog box that opens, select the toolbars you want

to see and click Close.

Hidden Geometry
Section Planes
Section Cuts
Axes

Guides
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Toolbars

Tooba'sl[}phonsl

Fiename...

Delete
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Drawing area

oThe drawing area is where you create your model.

EXp|OrIﬂg the oThe 3D space of the drawing area is identified visually by the
drawing axes, which provide a sense of direction in 3D space while

SketCh U p you work.

iﬂte rfa ce oThe drawing area also contains a simple model of a person to give
you a sense of 3D space.
—TFitle bar

—Menu-bar

—Getting Startedtoolbar
Drawing area
Status bar - Tips
Status bar - Measurements box

Window resize handle
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Exploring the
SketchUp
interface

Status bar - Tips
Status bar - Measurements box

Window resize handle

Status bar

oWhen you’re getting started with SketchUp, the two important
elements on the status bar are the tips in the middle and the
Measurements box on the right:

* Tips for using the tools: In the middle area of the status bar, click
the question mark icon to display the Instructor window, which
offers basic information about using whatever tool you select in
the toolbar. The middle area also displays a brief sentence about
using the selected tool. This area is helpful when you’re not sure

how a tool works. N@ O H S BECR| L EB G2 AN G

model,

(® @ | Erase, soften or smooth entities in the model.
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Status bar

* Measurements box: This box is a critical tool for creating accurate
models. The box displays dimensions as you draw. You can also

Exploring the use this box to manipulate currently selected entities (such as
creating a line that’s a specific length) or to create evenly spaced

SketCh U p copies of entities (such as columns, fencing, or housing blocks in
: a post-industrial dystopia).
I nte rfa Ce | Measurements I:I

—TFitle bar

NP /O E S ALCH 2 PRGN O

= NeRtEDar

—Getting Startedtoolbar

= DraWine area

—Status-bar-Tips

Status bar - Measurements box

Window resize handle

select |edt | statistics |

2| Qe [5]8)
-~

S Use the Interact Toolto change the

_ B the d...

® ® (@ | select end point or enter value. | Lenath 45 12"
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Window resize handle

oTo the right of the Measurements box is the window resize handle,
which you can click and drag to change the size of the application

Exploring the window.
SketchUp
interface

L = |l
Select | edit | statistics

EMH] Warehouse |F |ﬂ
w

| Measurements 4 = >

Window resize handle
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Learning How To Use SketchUp Tools

> As you use SketchUp, the Instructor and the status bar give you pointers on using each tool.
° The Instructor teaches you how to use the currently selected tool.

o To turn on the Instructor, open the Instructor dialog box in the Default Tray , or click the question mark
icon in the status bar.

o Here’s what the Instructor has to offer:
* An animation that shows basic use of the selected tool

A description of what the tool does

Steps for using the tool, which correspond to the animation

Modifier keys that enable the tool perform additional functions
Links to Knowledge Center articles about advanced functions of the tool
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earning How To Use SketchUp Tools

B Untitled - SketchUp
File Edit View Camera Draw Tools Window Help

NAE AR MY L IREC I Y3 Y I

AN

Select Tool
Select entities to modify when
using other tools or commands.

Tool Operation
1. Click on an entity.

Modifier Keys

Ctrl = Add an entity to set of
selected entities

Shift+Ctrl = Subtract an entity
from set of selected entities
Shift = Toggle whether an entity
s within set of selected entities
N A = Select all visible

ent? in model

® @ @ | Ready —_—

| Measurements

ITEC185 - INTRODUCTION TO DIGITAL MEDIA




Viewing the
SketchUp Quick
Reference Card

SketchUp Pro Quick Reference Card | Windows

Large Tool Set
Select (Spacebar) k a Mazke Component

pantucket ® (@ @ e ®
tne® ) Frechand
e
cre© @ @ roven
Arc Z&ZWM(A)
srontac ) B pe
Moe ) o0 o Pusviul®
Roae @ LY (@ rotowme
s [ ) omsem
TapeMease D JB RN Dimensions
protractor @ {2 Ten
Axes X ‘301’&
Onbit ©) ‘/gmm)
2@ D P ZoomWidow
tookAround @R ) Section Pane

Solid Tools
Outersheil W EB) intersect (ro)

o @) W) B Subtract Prod

meo W W Sokt o)

Middle Button (Wheel) Scroll  Zoom
Click-Drag  Orbit

Double-Click  re-center view ‘

Shift+Click-Drag  Pan
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Dynamic Components

Component Attributes g
Sandbox (Terrain)

from Contours @ BB From Scratch
e @ B o0
Drape a B Add Detai
mptde S

Standard Views

IsoO‘Top
o 1
pack ) B let

o B O vt
wisome @) O Hesnive
st @ @ Lo
Mmodmne’

Location
Add Location_ O Torsie Terran

Photo Textures. &
Warehouse
D Warehouse. g VGt Share Model.

shroCorpenen G B W0

SendtoLayOut o) (g Q Classifier (Pro)
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B SketchUp Pro 2016

Tool Overali Inctructi

2 Point Arc (A) Bulge specify bulge amount by typing a number and Enter
Radius  specify radius by typing a number, the R key, and Enter
Segments  specify number of segr by typing a ber, the S key, and Enter
Circle (O) Shift  lock current inferences
Radius  specify radius by typing a number and Enter
Segments  specify number of segments by typing a number, the S key, and Enter

. . Eraser () Ctrl  soften/smooth (use on edges to make adjacent faces appear curved)
Shift  hide
Vlewmg the Coi._ st
Follow Me Alt  use face perimeter as extrusion path

Expert Tip!  first Select path, then choose the Follow Me tool, then dlick on the face to extrude

L]
Line (L) Shift  lock in current inference direction
e C p u | C Arrows  lock direction; up = blue, right = red, left = green, and down = parallel/perpendicular

Length  specify length by typing a number and Enter

Look Around Eye Height _ specify eye height by typing a number and Enter

Reference Card == e A

Alt  auto-fold (allow move even if it means adding extra edges and faces)
Arrows  lock direction; up = blue, right = red, left = green, and down = parallel/perpendicular
Distance  specify move distance by typing a number and Enter
External Copy Array  n copies in a row: move first copy, type a numbe, the X key, and Enter
Internal Copy Array  n copies in between: move first copy, type a number, the / key, and Enter

Offset (F) Double-Click  apply last offset amount to selection
Distance  specify an offset distance by typing a number and Enter
Orbit (0) Ctrl  hold down to disable "gravity-weighted" orbiting
Shift_hold down to activate Pan tool
Paint Bucket (B) Ctrl  fill material - paint all matching adjacent faces

Shift  replace material - paint all matching faces in the model
Ctri+Shift  replace material on object - paint all matching faces on the same object
Alt  hold down to sample material
Push/Pull (P) Ctrl  push/pull a copy of the face (leaving the original face in place)
Double-Click  apply last push/pull amount to this face
Distance  specify a push/pull amount by typing a number and Enter

Rectangle (R) Dimensions  specify dimensions by typing length, width and Enter le. 20, 40
Rotated Rectangle Shift  lock in current direction/plane
Alt  lock drawing plane for first edge (after first click)
Angle, Dimensions  click to place first two corners, then type angle, width and Enter ie. 90, 20
Rotate (Q) Ctrl  rotate a copy
Angle  specify an angle by typing a number and Enter
Slope  specify an angle as a slope by typing arise, a colon (), a run, and Enter le. 3:12
Scale (S) Ctrl  hold down to scale about center
Shift  hold down to scale uniformly (don't distort)
Amount  specify a scale factor by typing a number and Enter le. 1.5 =150%
Length specify a scale length by typing a number, a unit type, and Enter ie. 10m
Select (Spacebar) Ctrl  add to selection
Shift  add/subtract from selection
Ctri+Shift  subtract from selection
Tape Measure (T) Cirl  toggle create guide or measure only
Arrows  lock direction; up = blue, right = red, left = green, and down = parallel/perpendicular
Resize resize model measure a distance, type intended size, and Enter
ITEC185 - INTRODUCTION TO DIGERIIMEDIA Shift  hold down and click-drag mouse to change Field of View




Creating your first 3D model in SketchUp

o Select the person, context-click the selection, and select Erase in the context menu that appears.
> In the Getting Started toolbar, select the Rectangle tool ().

> On the ground plane, in the space between the red and green axis, click the Rectangle tool cursor ( /£ ).
Then move your cursor to the right and click again. A rectangle appears on the ground.

Draw Tools Window Help

Entity Info v v m"é?E@yll
Hide .| E Rectangle R

Lock ! Rotated Rectangle

Edit Component ﬁ Circle C

Make Unique

Explode “ Palygon

Unglue
Reload...
Save As...

30 Warehouse

Change Axes
Reset Scale

D mmmt Tlrmans
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Creating your first 3D model in SketchUp

> On the Getting Started toolbar, select the Push/Pull tool ( &), and place the Push/Pull cursor over the
rectangle you just created, as shown in the following figure.

o Click and drag your rectangle up into a 3D shape. Keep an eye on the Measurements box and release
the cursor when your shape is about 5 feet tall.

=
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Creating your first 3D model in SketchUp

o Without clicking or selecting anything, simply type 6’ and press Enter.
> Notice how the height of your shape changed to exactly 6 feet tall, and the value you entered appears in

the Measurements box. swuses =
gz HE{ePeroF LrEB bz, OGS

Push/Pull Tool

Push and pull Face entities to
add or subtract volume from your
3d models.

Tool Operation

rsor to select a face.
. Click on the face.

. Move cursor to push or pull
face into 30 form.

Click to finish push/pull
operation.

. Esc = Cancel operation.

A o = wrna

) @ @ | Dragto push or pull face or enter value. Ctrl = toggle create new starting face.
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Creating your first 3D model in SketchUp

In the Getting Started toolbar, select the Orbit tool (g ).
Place the Orbit cursor above your shape.

(e]

(e]

(e]

Then click and hold while you move the mouse down.
> Notice how the view of your shape changes.

Tlo (80 Viem Cavwrs Ovme Tooh Window s
NG/ TR0 PHA G P K LO9 N
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Creating your first 3D model in SketchUp

> In the Getting Started toolbar, click the Zoom Extents button ().

° If you orbit around until you lose track of where you are in your model, the Zoom Extents button is a
handy way to reorient yourself.

eS8 e zpreowa
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Creating your first 3D model in SketchUp

° If you have a scroll-wheel mouse, scroll down to zoom out a bit.

o Working in SketchUp is much easier with a scroll-wheel mouse.

> However, if your mouse lacks a scroll wheel, click the Zoom tool ( ) and you can zoom in and out that
way, too.

S o@B ez o8

MR PO X
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Creating your first 3D model in SketchUp

> In the Getting Started toolbar, click the Paint Bucket tool ( & ).
° In the Materials dialog box that appears, select Colors from the drop-down menu.

> Then select a color from the options that appear on the Select tab.

indow Help

NEXT D).

SALCH L EB S ZLE OB
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Creating your first 3D model in SketchUp

Click one side of your model with the Paint Bucket cursor to apply your selected color.
Experiment a bit with the different options in the drop-down menu if you like.

For example, select Wood from the drop-down menu and apply Wood Floor to your model.
Orbit around and apply different materials to each side of your model.

B Untitled - SketchUp o X

(e]

(e]

(e]

(e]

File Edit View Camera Draw Tools Window Help

NGO H- ST LEB P zLHOER

@ ® @ | Select object to paint. Alt = Sample Material.
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Creating your first 3D model in SketchUp

Close the Materials dialog box and open the Styles dialog box in the Default Tray.

From the drop-down menu, select Sketchy Edges and then select a style option.

In the following figure, Marker Wide is selected.

Notice that the style completely overrides all the materials and colors applied.

To see them again, select In Model from the drop-down menu and then select the Simple Style option.

o

o

o

o

o

. Default Tray A |
» Entity Info EJ - —— N
> Materials Ix] » Materials &
> Components [x] —— o
¥ Styles | ¥ Styles &
7 | simole styie = Marker Wide a8
Default face colors. Blue sky @ E::EW wide tpped marker &
. and green background color. =
~ —
s
| | Select |Edt | Mmx |
! : : ¢ > fﬁ ISketchy Edges - ?
< Sketchy Edges 4 TN -
= In Model — -
f |7 Styles e @,. .
{  Assorted Styles Ll U
§  Color Sets = = Marker Wide| 4f |
Default Styles T = ] I
| Photo Modeling
3 Sketchy Edges ~
“|  straight Lines
Style Builder Competition Winners v
- — - - —
d (—/ » Shadows &
o | — ‘_.—_‘ ¥ Instructor [
= ~

o
]
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Saving and Reopening a Model

> On the menu bar, select File > Save.

o |f this is the first time you’re saving a model, the Save As dialog box appears.
> To save an already saved model with a new name, select File > Save As.

Open... Ctrl+0

i titled - SketchUp - [ X
it View Camera Draw Tools Window Help
- “N L FISOH L OB b ZLH OB

a Ctrl+S

Save A Copy As...
Save As Template...
Revert Simple Style &

Default face colors. Blue sky &

Send to LayOut and green background color. il
Geo-location > =
3D Warehouse > select [eat | mx |
Trimble Connect > <& D 2 [in vodel -
Import... Vg
Export > @
Print Setup...
Print Preview...
Print... Ctrl+P
Generate Report...

1 C:\Users\...\Untitled.skp
2 C:\Users\...\Untitled.skb
3 C:\Users\...\Desktop\Ex1.skp

Exit

@ @® @ | save the active model with a new name. | Measurements. [ ‘
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Saving and Reopening a Model

Use the Save In area at the top of the dialog box to select where you’d like to save your model.

o

o

In the File Name box, type a name for your model.

o SketchUp model files end with the .SKP file extension.
> Click the Save button. S Sovehs x
- « «» [l » ThisPC » Desktop » v B Search Desktop o
Organize « New folder == - e
. lecture notes # . 2
| RAD Studio A \i i) _' 3 Il
£# Dropbox ASP.MET Desktop ilk Yardim ITECTOS5 - ITECT07 - ITECIO7 -
2015 Kitaplan Introductio Adobe SketchUp
. nto lllustrator Lab
@ OneDrive Computers  Lab Exerci... Exercise
3 This PC . = N = S
[ Desktop = E b f E E =
Documents ITEC115_19 ITEC319-  |TEC414-E  |TEC44T- ITECK¥X - JD Edwards
0- Rapid Governmen WEB Programmi
¥ Downloads Bilgisayara  Aplication t Projects ng for
J, Music Girig_Huk... Develop.. Informatics
[&] Pictures v h N =i S ~—— .

File name: | SketchUplLect.skp|
Save as type: | SketchUp Models (".skp)

» Hide Folders | Save | Cancel |
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